分类目录归档:Tools

全网首发用iPhone Siri控制MikroTik设备

用iPhone上的快捷指令实现简单的MikroTik设备管理操作,可以很灵活的去实现自己想要的功能,并且可以用Siri去操作MikroTik设备,这是MikroTik app无法实现的,我个人还是很喜欢的。

设备情况及版本

  • iPhone X、XR [Version:iOS 13.3]
  • MikroTik RB951-2n [Version:6.40.8]

所需知识

  • 基础的网络知识
  • 基础的编程知识
  • MikroTik 脚本知识

继续阅读

Mikrotik 通过特定L7鉴权后发送当前系统配置文件到内网FTP

xx群主的奇思妙想😄

#修改鉴权密码,只能修改例子里面的数字部分其余字符不能修改会导致鉴权失败。
/ip firewall layer7-protocol add name=L7_FTP regexp=“^123456\$”
#修改鉴权端口号,和能访问的IP地址段或者IP地址。
/ip firewall filter add action=add-src-to-address-list address-list=L7_FTP address-list-timeout=none-dynamic chain=input dst-port=1234 layer7-protocol=L7_FTP protocol=udp src-address=192.168.87.0/24

继续阅读

微信好友被删检测工具

最近抖音看多了,就自己弄了个自动检测好友有没有删你的小程序,用Python开源库itchat写的,担心程序有病毒,上传数据的请不要下载使用。

本程序不上传和保存任何数据,也不连接任何个人服务器。

注意:

  1. 微信好友数量不对的,请重新运行程序。(程序偶尔只能获取到几个好友)
  2. 建议同一个微信账号最多检测2次。
  3. 由于这个小程序是利用微信网页版制作的,有些微信号默认是不能登录网页版微信的,所有这种情况是不能进行测试的。

测试过的系统版本:

  1. Windows7 旗舰版 版本号:6.1.7601 Service Pack 1 运行正常。
  2. Windows 10 企业版 2016 长期服务版 版本号:10.0.14393 运行无报错但是程序无法正常工作,建议更换电脑或者虚拟机的方式测试。

运行截图V1:(自动忽略错别字吧)
运行截图V1

继续阅读