月度归档:2015年08月

ROS 6.X 流量过高发送邮件。

直接贴代码:

:do {
:local arx
:local btx 
interface monitor-traffic pppoe-out1 once do={
:set arx $"rx-bits-per-second"
:set btx $"tx-bits-per-second" 
}
:local rxud ($arx  /1000000)
:if ($rxud>50) do={
:local smtp "smtp.qq.cn"
:local smtps [:resolve $smtp]
:local ports "25"
:local Mailings "e-mail@qq.cn"
:local pass "123456"
:local Collection "1432868020@qq.com"
:local Themes "警告!AD100M当前下载流量超过50M/s"
/tool e-mail set address=$smtps port=$ports from=$Mailings user=$Mailings password=$pass
/tool e-mail send to=$Collection from=$Mailings subject=$Themes body=("达到预设流量阀值 50Mbit/s\n当前下载流量 $rxud Mbit/s")
:log warning "下载流量超过设置阀值70Mbit/s 当前下载速率$rxud Mbit/s"
}
}

CentOS更改主机名。

查看主机名命令:

方式一[root@CentOS ~]# hostname
方式二[root@CentOS ~]# uname -n

实例:

[root@CentOS ~]# hostname
CentOS
[root@CentOS ~]# 

更改主机名命令:

hostname +要更改的主机名

实例:

[root@CentOS ~]# hostname openstack.example.com
[root@CentOS ~]# hostname
openstack.example.com
[root@CentOS ~]# 

Centos 配置网络。

设置IP地址、网关、DNS

vi  /etc/sysconfig/network-scripts/ifcfg-eth0
BOOTPROTO=static   #启用静态IP地址
ONBOOT=yes  #开启自动启用网络连接
IPADDR=192.168.21.129  #设置IP地址
NETMASK=255.255.255.0  #设置子网掩码
GATEWAY=192.168.21.2   #设置网关
DNS1=8.8.8.8 #设置主DNS
DNS2=8.8.4.4 #设置备DNS
IPV6INIT=no  #禁止IPV6(可选)

禁止IPV6(可选)

service ip6tables stop   #停止IPV6服务
chkconfig ip6tables off  #禁止IPV6开机启动
service yum-updatesd stop   #关闭系统自动更新
chkconfig yum-updatesd off  #禁止开启启动
service network restart  #重启网络连接

重新启动网络服务:

/etc/init.d/network restart

vi保存并退出命令
1.先按esc
2.输入分号:和wq(w是保存的意思q是退出的意思)