MikroTik NAT日志记录–简版小程序分享

记录MikroTIk路由器NAT日志,本程序可记录设备mac地址、源IP、源端口、目的IP、目的端口、使用的协议、数据包大小等字段,本程序使用SQLite3数据库,数据每天分库保存。

使用截图:

常用SQLite查询语句:


SELECT * FROM log WHERE dstip LIKE '%192.168%'; #模糊查询目的IP地址
SELECT * FROM log WHERE srcip='192.168.89.31'; #查询源IP
SELECT dstip, count( * ) AS count FROM log GROUP BY dstip ORDER BY count DESC LIMIT 10;#查询log 表中 dstip 重复次数最多的10条记录。

SQLite管理工具推荐:

Navicat Premium
Navicat for SQLite
SQLiteStudio

MikroTik脚本:

#修改192.168.11.100为接收MikroTik NAT日志记录电脑的IP。
/ip firewall nat set [find action=masquerade] log=yes
/system logging action add name=Server1 remote=192.168.11.100 remote-port=5140 target=remote
/system logging add action=Server1 topics=firewall,info

程序下载:MikroTik NAT日志记录
MD5:9e0c4f25b50fdf7bac3f7b32785b50d3

发表评论