Mikrotik 通过特定L7鉴权后发送当前系统配置文件到内网FTP

xx群主的奇思妙想😄

#修改鉴权密码,只能修改例子里面的数字部分其余字符不能修改会导致鉴权失败。
/ip firewall layer7-protocol add name=L7_FTP regexp=“^123456\$”
#修改鉴权端口号,和能访问的IP地址段或者IP地址。
/ip firewall filter add action=add-src-to-address-list address-list=L7_FTP address-list-timeout=none-dynamic chain=input dst-port=1234 layer7-protocol=L7_FTP protocol=udp src-address=192.168.87.0/24

#添加系统脚本每3s检查一次,并设置启动时间为开机启动。
#设置FTP用户名
:local FTPUser ali
#设置FTP密码
:local FTPPass ali
#设置FTP IP地址
:local FTPIP 192.168.87.1
:local count [/ip firewall filter get [find layer7-protocol=”L7_FTP”] packets]
if ($count>0) do={
/system backup save name=Back
:delay 3
/export file=Back
:delay 3
#上传加密的备份文件
/tool fetch mode=ftp address=$FTPIP src-path=Back.backup dst-path=/Back.backup user=$FTPUser password=$FTPPass upload=yes
:delay 1
#上传配置脚本未加密
/tool fetch mode=ftp address=$FTPIP src-path=Back.rsc dst-path=/Back.rsc user=$FTPUser password=$FTPPass upload=yes
/ip firewall fi reset-counters-all
}
如何发送鉴权密钥?
我们用sokit这个软件来向MikroTik发送鉴权密钥。
软件下载地址:http://cdn.rosm.cn/sokit-1.3.7z

打开软件单击“客户端”,填写相应的信息即可。
设置MikroTik的内网地址即网关地址。
设置我们上面脚本设置的UDP端口号。
鼠标单击“UDP通道”,这一步非常重要,是和MikroTik建立鉴权连接的。
在数据一栏中填入我们脚本里面设置的鉴权密钥,单击“发送”,30秒后就可以在FTP上看到备份的文件了。
如下图所示:

发表评论